Skip to end of metadata
Go to start of metadata

Sarkaimilla taulukkomaisen tekstin luonti käy kätevästi, mutta aina se ei riitä. Jos taulukkoon halutaan reunaviivoja tai muita erityismuotoiluja, tarvitaan ihan oikeaa taulukkoa. Uudemmissa tekstinkäsittelyohjelmissa Taulukko (Table) valikko sisältää runsaan valikoiman työkaluja taulukoiden luontiin ja hallintaan. Toiminto Lisää > Taulukko… (Insert > Table…) sisältää rivien ja sarakkeiden määrän ja sarakeleveyden valintojen lisäksi kokoelman valmiita taulukkopohjia, jotka voivat joskus olla hyvinkin käteviä, esim. pikataulukko… (AutoFormat…).

Taulukon luonti

Taulukon luonti onnistuu myös vakiotyökalurivin painikkeilla. Wordissa voit jopa valita,

a) piirrätkö taulukon itse Lisää > Taulukot > Piirrä taulukko (Insert > Tables > Draw tables ) -painike,

b) vai annatko Wordin luoda taulukon automaattisesti : Lisää taulukko (Insert Table) painike.

Molemmissa tapauksissa sarakkeita ja rivejä voidaan lisätä tai vähentää mielin määrin jälkeenpäin.

Piirrettäessä Taulukot ja reunat työkalulla on ensin piirrettävä taulukon ulkoreunat. Sen jälkeen kehikon voi jakaa sarakkeisiin ja riveihin. Taulukot ja reunat työkalurivi tulee esiin samalla kun vastaavaa painiketta painetaan – ja jää näkyviin, ellei sitä sulkemispainikkeella suljeta. Työkaluriviltä löytyy piirtotyökalun vaihtoehdoksi myös pyyhekumi viivojen poistoon, sekä työkalut viivojen näkymisen, värin ja paksuuden hallintaan, solujen täyttövärien valintaan, tekstin tasaukseen ja niin edelleen. Kun taulukko on piirretty, pitää piirtotyökalu tai vastaava vapauttaa jotta taulukkoon päästään kirjoittamaan.

Reunaviivoja voit hallita myös muotoilutyökalurivin monivalintapainikkeella, Aloitus > kappale (Home > paragraph ) jonka oletusnimenä on Ulkoreuna (Outside Border) ). Painamalla painikkeen oikealla puolella liitännäisenä olevaa nuolipainiketta saat esiin erilaiset reunavaihtoehdot valitulle taulukon alueelle.

Taulukossa on aina yksi solu aktiivinen, eli valmis vastaanottamaan tekstiä, minkä merkkinä siinä vilkkuu tekstikohdistin. Solusta toiseen pääset siirtymään sarkaimella (taaksepäin Vaihto+Sarkain) tai nuolinäppäimillä. Rivitys solun sisällä tapahtuu automaattisesti, ja jos viimeisen rivin viimeisessä solussa painat sarkainta, ohjelma lisää taulukkoon uuden rivin ja kohdistin siirtyy uuden rivin ensimmäiseen soluun.

Rivien ja sarakkeiden lisäys

Rivejä voidaan lisätä myös jo olemassa olevien väliin tai yläpuolelle komennolla painamalla hiiren oikeaa taulukon kohdalla ja valitsemalla Lisää. Rivejä voidaan lisätä vasemmalle/oikealle/ylä- tai alapuolelle (Mouses rightbutton,/insert / rows above/below/colums to the right/left…). Uusi rivi ilmestyy valinnan mukaan aktiivisen solun tai valitun rivin ylä- tai alapuolelle. Myös sarakkeen lisääminen valitun solun vasemmalle tai oikealle puolelle on mahdollista.

Rivejä tai sarakkeita voidaan myös lisätä useita kerralla: kun valitset useita rivejä tai sarakkeita ja annat Lisää rivejä tai sarakkeita komennon, uusia rivejä tai sarakkeita ilmestyy yhtä paljon kuin entisiä oli valittuina. Rivien ja sarakkeiden reunoja voit siirtää hiirellä vetämällä.

Solujen valinta

Kun halutaan muotoilla solussa olevaa tekstiä, se valitaan ensin samalla tavalla, kuin mikä tahansa teksti. Kohdistaessasi muotoiluja koko soluun tai ryhmään vierekkäisiä soluja (esimerkiksi reunukset tai täyttöväri), ne pitää ensin valita hiirellä "maalaamalla". Solu on valittu silloin, kun se kokonaisuudessaan on saanut mustan (tai värillisessä solussa jonkun muun) taustavärin, ei vain sen sisältämä teksti.

Rivin valinta

Rivin valinta tapahtuu napsauttamalla hiirellä taulukon ulkopuolella valittavan rivin vasemmalla puolella. Nappia alhaalla pitäen voidaan valita useita rivejä tai koko taulukko. Sama onnistuu toki myös näppäimillä vaihtonäppäintä alhaalla pitäen. Valittu (valkoinen) rivi saa mustan täyttövärin.

Huomaa, että rivin valinnan merkkinä täyttöväri jatkuu hieman taulukon oikean laidan ulkopuolella. Ilman tätä jatketta vain rivin solut ovat valittuina. Myöskin sarakkeita voidaan valita, lisätä tai poistaa: kun viet osoittimen taulukon yläpuolelle, se muuttuu mustaksi, alaspäin osoittavaksi nuoleksi, jolloin napsautus valitsee koko sarakkeen ja hiiren siirtäminen vaakasuoraan nappi alhaalla useita sarakkeita.

Rivin, sarakkeen ja sisällön poistaminen

Valitun solun, rivin, sarakkeen tai koko taulukon sisällön poistat helposti Delete-näppäimellä. Valitut rivit tai sarakkeet poistat painamalla hiiren oikeaa nappia ja valitsemalla Poista solut. Voit poistaa rivejä, sarakkeita tai siirtää soluja ja sarakkeita vasemmalle tai ylös.

Lisätietoa

>> Taulukon lisääminen, tekstin muuttaminen taulukoksi tai taulukon piirtäminen (Microsoft)

>> Taulukon poistaminen (Microsoft)

Taulukon työkalut

 Kun aktivoit taulukon tai osan siitä, saat työkalurivin loppuun taulukon työkalut (Table tools), jossa on

Asettelu (Design), jossa voit määritellä taulukolle teeman, reunaviivat jne.

Ulkoaseu (Layout), jossa voit mm. määritellä lisää rivejä ja sarakkeita tai poistaa niitä.