Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Migrated to Confluence 4.0

CamStudio 2.0 on ohjelma, jolla voi nauhoittaa tietokoneen kuvaruudun tapahtumat.
Ohjelma tallentaa videon AVI-muodossa, mutta sen (tai jonkun muun AVI-tiedoston) voi koodata myös SWF Flash-muotoon.
Ohjelmalla voi myös nauhoittaa suoraan Flash-muotoon. 
Ohjelmaa saa käyttää ilmaiseksi GNU-lisenssin mukaisesti.

Ohjelman asetukset

File-valikossa on

  • Record - tallenna
  • Stop - pysäytä
  • Pause - pysäytä hetkeksi
  • Exit - sulje ohjelma


 

Regions-valikossa määritä nauhoitettava alue:

  • region => pyytää määrittämään alueen (hiirellä rajaten) nauhoituksen alussa
  • fixed region => määritä alueen koko ja sijainti
  • Full Screen - koko tietokoneen näyttö

Options -valikossa määritellään videon asetukset ja otetaanko mukaan audio ja esim. kursori

Tarkemmat kuvat video ja kursori astuksista taulukon alapuolella.

Tools-valikossa määrittelet:

  • Screen Annotatios eli näyttääkö ruutukaappauksen aikana erilaisia muotoja, joihin voit vaihtaa tekstiä.
  • Video Annotations eli ...?
  • SWF Producer - aloittaa AVI-tiedoston koodauksen FLASH-tiedostoksi.

View-valikossa voit määrittää, millaisena haluat ohjelman näkyvän työskentelyn aikana

 




 

Nauhoittaminen

  1. Tarkista ohjelman asetukset haluamaksesi.
  2. klikkaa punaista record-painiketta ohjelman vasemmassa yläkulmassa
  3. Jos olet asetuksissa määrittänyt aluee, sinun pitää rajata alue.
  4. Tee tietokoneella haluamasi toiminnot
  5. Lopeta nauhoitus sinisestä neliöstä ohjelman yläpalkissa.

Jos haluat nauhoittaa suoraan FLASH-tiedostoksi napsauta ikonien oikeassa reunassa SWF-painiketta.
AVI-muotoon saat napauttamalla painiketta suoraan.


AVI-tiedoston koodaus FLASH-tiedostoksi

Valmiin AVI-tiedoston voi koodata FLASH-tiedostoksi: 

  1. Valitse ohjelmassa Tools > SWF Producer

Sinulle aukeaa SWF-player, josta
1. Valitse open ja valitse AVI-tiedosto (kts. kuva alla)

2. AVI-tiedosto aukeaa playeriin.
3. Valitse playerin ylävalikosta Convert to SWF
4. Välilehdillä (kuvat alla) voit määrittää tarkemmin FLASH-tiedoston asetukset:

Tip

General-välilehdellä kannattaa Keyframe olla 20.
Huomoi, että www-maailman tiedostonimeämissäännöt!


 

Ohjelma julkaisee kohdekansioon kaksi tiedostoa:

1. html-tiedosto, johon on upotettu FlASH-tiedosto

2. Itse FLASH-tiedosto (*.swf), jonka voit linkittää esim. wikissä/Moodlessa tms.

Esimerkit

Esimerkki1 - luokan määrittäminen Outlook kalenteri-merkintään

Lisätietoa 

Kotisivu: http://camstudio.org/