Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Info

Funktio (engl. function; lat. functio = toimitus, tehtävä) on "valmiiksi kirjoitettu kaava, joka ottaa käsittelyyn yhden tai useita arvoja, suorittaa laskutoimituksen ja palauttaa yhden tai useita arvoja.

 

 

 

Funktioita käytetään laskentataulukon yksinkertaistamiseen ja lyhentämiseen, erityisesti jos ne suorittavat pitkiä tai monimutkaisia laskutoimituksia" (Microsoft Excelin Ohje). Eri käyttötarkoituksille on omat funktionsa, ja käyttötarkoitus ilmenee yleensä jo funktion nimestä. Esimerkiksi SUMMAfunktio laskee yhteen solujen arvot ja MAKSU-funktio laskee lainan maksuerät korkoon, lainan maksuaikaan ja lainasummaan perustuen. Normaalista kaavasta funktio eroaa siten, että sen laskutoimituksia ei tarvitse kirjoittaa näkyviin, jolloin se näkyy käyttäjälle vain funktion nimenä sekä välittömästi sen jäljessä suluissa olevina argumentteina.

...

Funktion argumentit

...

 eli parametrit

...

 tai muuttujat

...

 sisältävät laskentaan tarvittavat arvot. Argumentit ovat useimmiten soluviittauksia, mutta ne voivat olla myös numeroita, tekstiä, totuusarvoja (TOSI/EPÄTOSI), virhearvoja (esim. #PUUTTUU!), tai matriiseja. Argumentit voivat olla myös vakioita, kaavoja tai myös funktioita.

Funktioiden kohdalla taulukkolaskentaohjelmien kielierot korostuvat: funktioiden nimet ovat samankielisiä kuin itse ohjelmakin, eikä ohjelma ymmärrä muunkielisiä funktioiden nimiä.

On huomattava, että ohjelman käyttämä kieli ja Windowsin maakohtaiset asetukset ovat kaksi eri asiaa: esimerkiksi Excel voi olla englanninkielinen, mutta käyttää suomalaisia maa-asetuksia, eli pilkkua desimaalierottimena, puolipistettä funktioiden argumenttien erottamisessa toisistaan jne.

Niinpä SUMMA-funktio on englanninkielisessä Excelissä SUM ja KESKIARVO puolestaan AVERAGE.

Tip

Onneksi ohjelma osaa päivittää funktioiden nimet toisen kielen mukaisesti, jos tiedosto aukaistaan toisenkielisessä ohjelmassa.

Funktion lisääminen 

Kirjoittaen käsin kaavariville

Funktio otetaan käyttöön kirjoittamalla aktiiviseen soluun (tai kaavariville) yhtäsuuruusmerkki, funktion nimi ja nimen jälkeen funktion tarvitsemat argumentit suluissa, esimerkiksi =SUMMA(B3:E5).

Käyttäen Lisää Funktio -toimintoa

Usein funktio kuitenkin lisätään vakiotyökalurivin Summa (Sum) painikkeella (avaa summa-painikkeen lisävalikko) tai – luonnollisesti – myös valikkokomennolla Kaavat/Lisää Funktio… (Function/Insert Function…). Komento avaa Funktion lisääminen (Paste function) -ikkunan (kuvat alla), jossa funktiot on ryhmitelty luokittain, ja valittu funktio liitetään painamalla OK-painiketta tai Enteriä. Komennon käyttö luo automaattisesti funktion nimen eteen tarvittavan yhtäsuuruusmerkin.

 

Image Removed  Image Removed

      

Suomenkielisen Excelin Funktion lisääminen -ikkuna ja vastaava Paste Function -ikkuna englanninkielisessä Excelissä. Tiettyjä funktioita käytetään hyvin runsaasti, joten usein sopiva funktio löytyy luokasta Viimeksi käytetyt (Most Recently) Used. Valittuna olevan luokan sisältö näkyy alapuolella, ja sieltä valittu funktio liitetään aktiiviseen soluun painettaessa OK-painiketta (tai Enteriä). Valitun funktion kuvaus näkyy ikkunan alalaidassa. Koska kuvat ovat eri ohjelmista, Viimeksi käytetyt -luokan sisältö ei ole ikkunoissa aivan sama.  

...





 

Image Added


Image Added

Kun funktio on valittu, ohjelma yleensä ehdottaa sille argumenteiksi joko aktiivisen solun vasemmalla puolella tai yläpuolella olevien solujen osoitteita erillisessä argumenttien valintaikkunassa (kuva yllä). Ikkuna avautuu automaattisesti.

Ikkunan voi siirtää hiirellä sivummalle, tai pienentää argumenttien syöttörivin lopussa olevalla värikkäällä painikkeella pelkäksi syöttöriviksi. Ohjelman valitsemat argumentit voidaan korjata vaihtaa oikeiksi valitsemalla hiirellä sopiva solualue, tai kirjoittamalla

...

ne Luku1-riville. Luku2-riviä tarvitaan harvemmin. Ikkuna näyttää myös valitun funktion kuvauksen sekä laskennan lopputuloksen käytössä olevilla argumenteilla. Ehdottomasti yleisimmin käytetty funktio on SUMMA (SUM), jolla voidaan kertaheitolla laskea hyvinkin laajan alueen kaikkien solujen arvojen summa. Se on jopa niin paljon käytetty, että aina kun käyttäjä valitsee taulukosta solualueen, tilarivillä näkyy automaattisesti alueen lukujen summa. SUMMA-funktiolla on myös oma isolla Sigma () kirjaimella varustettu painikkeensa vakiotyökalurivillä (huomaa painikkeeseen liittyvä lisävalikko). Summa-painiketta käytettäessä yhteenlaskettavat solut voivat olla valmiiksi valittuina, jolloin ohjelma ei pyri tarjoamaan vaihtoehtoista solualuetta summattavaksi.

Funktioita voidaan käyttää myös sisäkkäin tai kaavojen osana. Esimerkiksi =PYÖRISTÄ(KESKIARVO(D3:F8);2)+B12 on kaava, sillä siinä on erillinen laskutoimitus: kahden sisäkkäisen funktion arvoon lisätään solun B12 arvo.

Liitä funktio -ikkunan funktioiden kuvaukset ovat yleensä riittävä ohje funktioiden käytöstä. Taulukkolaskentaohjelman ohje sisältää lisäksi yksityiskohtaisen ohjeen esimerkkeineen jokaisesta funktiosta. On silti lukuisia funktioita, joiden ymmärtäminen ja oikea käyttö voi edellyttää jonkin tieteenalan syvällisempää ymmärtämistä, vaikkapa tilastotieteen FJAKAUMA (FDIST) tai rahoituspuolen DDB-funktio.

VIrhetilanteet 

Image Added

Kaavarivi ja välittömästi sen alapuolella argumenttien valintaikkuna. Kaavarivillä näkyy valittu funktio valintaikkunan argumenteilla varustettuna. Huomaa, että sana KESKIARVO esiintyy myös kaavarivin alussa: nimiruudun tilalla on viimeksi käytettyjen funktioiden valintalistaus (nuolenkärkipainike) silloin kun kaavariville on kirjoitettu yhtäsuuruusmerkki tai muulla tavoin aloitettu kaavan luonti tai funktion liittäminen.

Virhetilanteet 


Funktioiden käytössä voi tulla virheitä kuten kaavoissa normaalistikin. Virheet argumenteissa eli parametreissa aiheuttavat yleensä virheilmoitusikkunan avautumisen (kuva alla), mutta mikäli funktion nimi on kirjoitettu väärin tai on vääränkielinen, funktion arvoksi tulee virheilmoitus #NIMI? (#NAME?).

Image Modified

Lisätietoa

>> Video: Funktioiden käyttäminen Excel 2013:ssa (Microsoft) n. 5 min